0
Welcome Guest! Login
0 items Join Now

Our Valentine's Day Sale is coming to an end, but it's not too late to save big! It's your last chance to save 50% on themes and 35% on memberships!
motionmailapp.com

SOLVED Problem after Gantry 5.4.29 update

  • SOLVED Problem after Gantry 5.4.29 update

    Posted 6 months 3 weeks ago
    • Hi,

      After updating Ganbtry to version 5.4.29 I have a problem with one of my RSForm forms. Normal forms just work fine, but the form which should result in a payment transaction at a payment provider doesn't work properly anymore. After submitting the form a page of the patment provider should beopened, but this is not working anymore. Instead I get a blank screen as a result of too many redirects for favicon.ico. As soon as I install Gantry 5.4.28 again everything is working again.

      Do you have any suggestions? You will find the site details in the secure tab.

      Best regards,

      Joep
    • Last Edit: 6 months 3 weeks ago by Joep van Stratum.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87751
    • Thanks: 11349
    • Web Designer/Developer

    Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 6 months 3 weeks ago
    • Can you give me the exact steps to recreate the issue please.

      Also, you galatea template is out of date - so please backup and update to latest version.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 6 months 3 weeks ago
    • Hi Mark,

      Thank you for your quick responmse. I have updated the Galatea template to the latest version. Tested it again and the problem is the same.

      Steps to reproduce:

      - Update Gantry to 5.4.29
      - Fill out the form (url in the secure tab) and press the button labeld "Bestellen & betalen"

      Expected result: You are redirected to payment provider Mollie.com to finish the (iDEAL) payment

      Actual result: You end up on a blank page
    • Last Edit: 6 months 3 weeks ago by Joep van Stratum.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87751
    • Thanks: 11349
    • Web Designer/Developer

    Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 6 months 3 weeks ago
    • I enabled "debug" mode in Joomla global configuration. Then, somewhat ironically, the site then works (i've left it like that so you can see for yourself).

      Normally this situation can occur if the code you are using is attempting to use jQuery but has not loaded it itself. You will need to discuss this with the developer of RSForm as RT does not provide support for third-party products.

      Other suggestions would be to try disabling sh404sef and clear server cache (and indeed all other third-party products, one at time, clearing server and browser cache between each change) until you find the culprit.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 2 months 4 weeks ago
    • Hi Mark,

      I still didn't find a solution to this. Meanwhile I've tried also Gantry 5.4.30 and 5.4.31, but the problem remains. Last week I made a copy of the site and renoved all third party extensions, except RSForm and cciDEAL. That did not solve the problem. Also enabling/disabling jQuery in the template setting did not make a difference. Neither did changint to another RT theme. The only way to get it working again is to downgrade Gantry to 5.4.28.


      I have ciontacted David de Boer of Chill Creations, the devoloper of cciDEA,L and passed on your comments to him. He doubts jQuery is the cause. After the form is completed RSForm saves the form. Then cciDEL kicks in and performs a reciredt to the pament provider. For some reason the redirect goes wrong.

      David asked me to send him a diff regarding the changes in 5.4.28/5.4.29, so he can do some further investigation. Would you be willing to provide me that?

      Regards, Joep
    • Last Edit: 2 months 4 weeks ago by Joep van Stratum.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87751
    • Thanks: 11349
    • Web Designer/Developer

    Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 2 months 4 weeks ago
    • All release of Gantry 5 are available here https://github.com/gantry/gantry5/releases - so from those you can work out the differences using winmerge (or equivalent).

      Regards, Mark.
    • The following users have thanked you: Joep van Stratum

    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: SOLVED Problem after Gantry 5.4.29 update

    Posted 3 weeks 1 day ago
    • Issue solved, the cciDEAL developers made some changes.

Time to create page: 0.087 seconds