0
Welcome Guest! Login
0 items Join Now

Gantry 5 - Updating templates with older G! versions

    • Joombler's Avatar
    • Joombler
    • Elite Rocketeer
    • Posts: 633
    • Thanks: 4
    • Hurrah

    Gantry 5 - Updating templates with older G! versions

    Posted 6 years 6 months ago
    • Just curious: can any working RT template with Gantry handle/survive a Gantry 5.x update? Should we use a special procedure to acomplish this without problems? Thanks, Joombler
    • With both feet on the ground you won't make any step forward...
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 96201
    • Thanks: 12722
    • Web Designer/Developer

    Re: Gantry 5 - Updating templates with older G! versions

    Posted 6 years 6 months ago
    • Gantry 4 and Gantry 5 are two different frameworks and templates have to be designed for that Gantry version. Please read this Blog item on Gantry 5 Backwards Compatibility - http://www.rockettheme.com/blog/team/171-gantry5-regarding-backward-compatibility .

      You can have both Gantry 4 and a g4 template installed at the same time as Gantry 5 and a g5 template. But, I would not do this on a production site as when you install Gantry 5 and g5 template it will make the new template the default and also add a new menu and make that default too.

      Regards, Mark.
    • The following users have thanked you: Amgeek

    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • Joombler's Avatar
    • Joombler
    • Elite Rocketeer
    • Posts: 633
    • Thanks: 4
    • Hurrah

    Re: Gantry 5 - Updating templates with older G! versions

    Posted 6 years 6 months ago
    • As J! will upgrade its versions, RT mostly follows its templates for these versions. Are you considering changing the upgraded templates made ready for later G! versions?
    • With both feet on the ground you won't make any step forward...
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 96201
    • Thanks: 12722
    • Web Designer/Developer

    Re: Gantry 5 - Updating templates with older G! versions

    Posted 6 years 6 months ago
    • Gantry 4 and it's templates wil continue for some time yet - they form the bulk of our portfolio of templates so we won't be abandoning them. When J3 came out we took the decision to have a cut-off point (a date prior to which we would not update older templates) - I suspect we would do the same when Joomla 4 comes out. It would also be fair to say that going forward new templates will be built on the Gantry 5 framework (Callisto being the first).

      I hope that answers your question.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.087 seconds