0
Welcome Guest! Login
0 items Join Now

Gantry 5 ready for Joomla 4.0 upgrade?

  • Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • Hi Mark,

      I understand that many of the Rok modules will not be compatible with Joomla4. I've found your module, RokCheck, to be very helpful. Will that module be able to move up to Joomla 4?

      Thank you,
      Geoffrey
    • Geoffresh Inc Digital Marketing - Affordable Internet Marketing, SEO Web Design, Online Marketing Consulting
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 98200
    • Thanks: 13048
    • Web Designer/Developer

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • I just tried it and it does work fine. The only thing of note is it's missing a few colors but I probably won't bother fixing that.

      Regards, Mark.
    • The following users have thanked you: Geoffrey13

    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • It's fantastic that you've already approved the Helium and Hydogen themes for testing.
      I agree with you that it is far from necessary to upgrade productive projects to Joomla!4. But I am a web developer and have to implement new projects every month, which I would like to do with my favorite template framework Gantry5. However, it is difficult to start a new project and still have to use J!3 because Gantry5 is not yet usable for J!4. I can't tell the customer that he'll have to pay again for a migration in a few months. And I can't wait to start the project because I have to make money ;-)

      I will now start the first project with Gantry5.5 and also support the test.

      I have a question about this right away:
      Is it possible to update an existing J!3-project with Gantry5.last to J!4 with Gantry5.5 or is this practice not yet recommended?
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 98200
    • Thanks: 13048
    • Web Designer/Developer

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • You can update an existing project from G5 to G5.5 - but it's one way only, you can't go back because of the huge changes. Also, G5.5 has bugs and is nowhere near stable at the moment (for example menu editor is currently broken). Also, your only choice would be to use Helium or Hydrogen (no RT template will work).

      So, as I said above and in my update https://rockettheme.com/forum/announcements-all/287041-joomla-4-and-j3-10-your-questions-answered right now it would be foolhardy to update an existing site, or even start developing a new site, using G5.5.

      Regards, Mark.
    • Last Edit: 10 months 1 week ago by MrT.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • I'm willing and able to test Gantry 5.5 on one or more non-production sites with Aurora, Horizon, Kraken, Notio, and Xenon.

      Thanks for all you do and especially for your quick replies.

      Todd
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 98200
    • Thanks: 13048
    • Web Designer/Developer

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 week ago
    • Thanks for the offer of help but only hydrogen and helium are ready for testing yet - All the RT templates will need an update and we're not ready to do them yet.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • jayjayr's Avatar
    • jayjayr
    • Hero Rocketeer
    • Posts: 306
    • Thanks: 1

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 day ago
    • I tend to agree with you Mark. Upgrade why? Just because it is the latest. But what is on it? Not much as it seems.
      What seems is that the joomla team entered the planned obsolescence era and provoqued the inevitable dissatisfaction of the clientelle avidly looking for "the latest".
      From my point of view this obsolescence was not well programmed, otherwise it should be done trying to cooperative work with all contributors to joomla richesse that is templates and other components developers. Or... it was really well programmed
      Regarding the loyal rockettheme users like me it is a bit frustrating not having the gantry 4 templates updated to joomla 4. On the other hand it is perfectly acceptable wait some month for gantry 5.5
      What is annoying is to see everyday the upgrade message in the administrator and also all the emails received for every website that has the effect of rushing us to the upgrade, that is exactly the intended objective, IMHO.
      I though many times if this step, announced almost since the version 3 was born, will not end up in a big buy like what happened with cPanel.
      Well... What it seems is that I have to start looking at the sites I have to upgrade from gantry 4 to 5.5
      And... Expect to do it before joomla 5 arrive, Or even... have to pay for joomla.

      Regards,
      Jay
    • Trying to learn something every day
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 98200
    • Thanks: 13048
    • Web Designer/Developer

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 day ago
    • jayjayr - Thank you for your comments. If you are getting an "upgrade" notification from joomla then if it's for J3.10.1 then that's fine - you can upgrade. If it's for j4.0.2 then make sure that you have joomla update set to the correct update channel (which shoul dbe "default" rather than "joomla next" then you shouldn't get any messages about j4 upgrade.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • jayjayr's Avatar
    • jayjayr
    • Hero Rocketeer
    • Posts: 306
    • Thanks: 1

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 day ago
    • Hi Mark, thank you for your answer. Please confirm just to be sure. It is ok to make now the upgrade to J3.10.1 for ALL sites, gantry 4 or gantry 5?

      And for J4 only after gantry 5.5 is tested and running, correct?

      Regards,
      Jay
    • Trying to learn something every day
    • Rae French's Avatar
    • Rae French
    • Elite Rocketeer
    • Posts: 624
    • Thanks: 17
    • IT Consultant

    Re: Gantry 5 ready for Joomla 4.0 upgrade?

    Posted 10 months 1 day ago
    • jayjayr wrote:
      Well... What it seems is that I have to start looking at the sites I have to upgrade from gantry 4 to 5.5

      Jay, don't upgrade to Gantry 5.5 yet. You'll break your sites. You should, however, be upgrading from Gantry 4 to Gantry 5 so that you will be ready when Gantry 5.5 is ready for Joomla 4.
    • Best wishes,
      Rae

Time to create page: 0.106 seconds