0
Welcome Guest! Login
0 items Join Now

Joomla 4 (and J3.10) - your questions answered.

    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 98152
    • Thanks: 13040
    • Web Designer/Developer

    Joomla 4 (and J3.10) - your questions answered.

    Posted 10 months 6 days ago
    • Please always ensure that you are using the latest version of J3.10.x as Joomla have released fixes.

      As you are no doubt aware, this week Joomla finally released Joomla 4 (after many years of development and missed deadlines). As a result many of you have been asking questions in the forums about our products and their compatibility with J4. I've tried to answer these questions below and will keep this topic updated as more questions arise.


      Gantry 4 and it's templates

      As we announced a long time ago, Gantry 4 and all of it's templates are NOT be compatible with Joomla 4 and we will not be updating them to make them so. The code base for Gantry 4 is over a decade old now and far too complex to be updated, this was one of the reasons that we introduced Gantry 5 some years ago to supersede Gantry 4.

      Over the past few years we have ported some of our more popular G4 templates to the G5 framework. That said, this activity has largely reached a conclusion and it is unlikely that we will be porting any further G4 templates to G5.

      You can carry on using G4 and your G4 template on J3.10. Joomla released J3.10 at the same time as J4 because they knew it would be hard for many people to make the leap to J4 on day 1. Joomla have committed to supporting J3.10 for a further two years with security releases and bug fixes so there is no immediate necessity to upgrade your site.


      Gantry 5 and it's templates

      Gantry 5 and it's templates are fully compatible with J3.10.x (Preupdate checker reporting is now fixed and correctly shows information). You can be confident in using Gantry 5 and it's templates with J3.10.x without any issues.

      For the past few months our team have been busy working on the developments necessary to make Gantry 5 compatible with Joomla 4. We could not finalise this work until the official release of Joomla 4. The release of Gantry 5 that will work with Joomla 4 will is known as Gantry 5.5.

      Gantry 5.5 incorporates many changes other than just Joomla 4 compatibility, it has required substantial testing and we are happy that it is stable.

      Our first step was to get Gantry 5.5, Helium and Hydrogen templates working on Joomla 4. After this then our entire portfolio of Gantry 5 templates will also need to be updated (so this may take some time).

      Update: All Joomla Gantry 5 template have been updated to work with Joomla 4, Wordpress and GRAV updates will follow.

      Extensions

      As you may have noticed, we have gradually been retiring our free extensions to "legacy" status (meaning that we no longer support them). A prime motivator for this is because most use MooTools and this often conflicts with modern JQuery based programs. Now, with the introduction of Joomla 4, Joomla has removed Mootools and a number of other components on which some of the extension depend. There are some workarounds, but we still need to complete a final assessment of which extensions work, work with work arounds, or comletely fail with J4. I will add further information here when I have it.

      Gantry 5 introduced "particles" as alternatives to most of the RT extensions and ideally you would be using these now rather than relying on the very old MooTools based extensions.



      Tips

      Several members have reported that once they have updated to J3.10 Joomla is nagging them (through notifications in joomla admin) to update to Joomla 4. If you experience this please go to components > joomla update > click on the "options" button and make sure that the update channel is set to "default" (in some cases, even if it is, change it to one of the others, save, and then change it back to "default" and save again) - the "default" channel will then mean that only updated to J3.10 are shown. Also, having updated to J3.10 be sure to log out and log back in again to see up to date information).

      The new preupdate checker in J3.10.2 does now show that G5 is compatible with J3.10.2. The preupdate checker has now been fixed and shows the correct information for Gantry5, Gantry 4, and RT extensions and templates.



      I hope that information is useful - I will keep this topic updated.


      Regards, Mark.
    • Last Edit: 4 months 2 weeks ago by MrT.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.093 seconds