0
Welcome Guest! Login
0 items Join Now

Rokgallery Not Displaying Correctly In HTTPS

  • Rokgallery Not Displaying Correctly In HTTPS

    Posted 6 months 2 weeks ago
    • Template: Topaz
      Joomla Version - 3.8.5

      I have a problem with some rokgallery modules I have on my site. They load correctly if they go to the http:// of the site, but not the https:// of it. Here are a couple of examples:

      www.ttsgranite.com/portfolio - displays normally
      www.ttsgranite.com/portfolio - broken

      www.ttsgranite.com/bathroom - displays normally
      www.ttsgranite.com/bathroom - broken

      I know that we ultimately need to do the forward to everything going to https, but before I can do that, I need to have these galleries working correctly.

      Your help, as always, is appreciated.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 78032
    • Thanks: 9652
    • Web Designer/Developer

    Re: Rokgallery Not Displaying Correctly In HTTPS

    Posted 6 months 2 weeks ago
    • You don't appear to have an active Joomla subscription?


      Please would you post your URL, superuser id and pswd in the secure tab of your post and I'll have a look for you.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: Rokgallery Not Displaying Correctly In HTTPS

    Posted 6 months 2 weeks ago
    • This message contains only secure information that is visible to MrT, moderators and administrators
  • Re: Rokgallery Not Displaying Correctly In HTTPS

    Posted 6 months 2 weeks ago
    • Mark,

      I have provided the secure information as requested.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 78032
    • Thanks: 9652
    • Web Designer/Developer

    Re: Rokgallery Not Displaying Correctly In HTTPS

    Posted 6 months 2 weeks ago
    • Ok fixed. It's your use of the "system page cache" plugin causing the issue. First, I wouldn't use it anyway because your pages are not static, they are constructed dynamically. Next, if you cache with http and then a person uses https (or vice-vera) then the page cache will be wrong anyway (hence the issue you see). It get's even worse if you consider mobile devices caching the page and then a desktop coming along and trying to use the cache.

      I disabled the plugin and I recommend you turn it off anyway, although you could try it again once you have completed the change to https permanently (with redirect) so you only use the one protocol to access your site.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.193 seconds