0
Welcome Guest! Login
0 items Join Now

SOLVED WP Rokgallery links not updating to https

    • Wicko's Avatar
    • Wicko
    • Elite Rocketeer
    • Posts: 792
    • Thanks: 7
    • Self employed Graphic designer with over 20 years of experience in branding, retail packaging and web design.

    SOLVED WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • We have added an SSL to our website running RokGallery. All links are now changed to https except images from RokGallery using in post featured images are still http and are causing our site to not load correctly.

      Talkmobile Blog

      How can I change this?
    • Last Edit: 2 years 11 months ago by Wicko.
    • This image is hidden for guests.
      Please log in or register to see it.

      Wicko Design is a multi-disciplined creative agency based in the South East of England. Specialising in web design and development, retail packaging and brand identity.

      http://www.wickodesign.com
    • Matt's Avatar
    • Matt
    • Preeminent Rocketeer
    • Posts: 20628
    • Thanks: 2924
    • messin' with stuff

    Re: WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • so you've updated your SITE and HOME URLs in the WordPress Admin to
      https://yourdomain.com
      ?
      .... that should be all you need to do... blow out any caches you may have running
    • Last Edit: 2 years 11 months ago by Matt.
    • SEARCH the forum first! These boards are rich in knowledge and vast in topics :woohoo:
    • Wicko's Avatar
    • Wicko
    • Elite Rocketeer
    • Posts: 792
    • Thanks: 7
    • Self employed Graphic designer with over 20 years of experience in branding, retail packaging and web design.

    Re: WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • Hi Matt

      Yes both site and home urls are set to https. If I set the site to https then I am locked out of the Wordress admin and times out.
      The url link is not simple as the main url is on onother server and the WordPress blog in on this server. Both have the same SSL and both also have load balancers. I am also searching for a server issue over these but was just checking to see if there was anything else I might have missed.

      RokGallery still doesn't create thumbnails but that is another issue. ;o)

      regards

      David
    • This image is hidden for guests.
      Please log in or register to see it.

      Wicko Design is a multi-disciplined creative agency based in the South East of England. Specialising in web design and development, retail packaging and brand identity.

      http://www.wickodesign.com
    • Wicko's Avatar
    • Wicko
    • Elite Rocketeer
    • Posts: 792
    • Thanks: 7
    • Self employed Graphic designer with over 20 years of experience in branding, retail packaging and web design.

    Re: WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • It appears that the issue was in fact on the server and the way the load balancer was handling the https.

      Comment from server company:

      What I saw when looking at this is that the header X-Forwarded-Proto is showing "http" regardless of whether the request uses http or https. I am not sure why that is, but I assume it has to do with the levels of proxying from Nginx --> Load Balancer --> Server. I'm guessing that X-Forwarded-Proto is already set when the load balancer gets the request, so it doesn't update it to https. Or perhaps you are terminating SSL at Nginx, and sending the request to the load balancer via http?

      At any rate, we normally use a statement like this in the Apache config:

      SetEnvIf X-Forwarded-Proto https HTTPS=on

      This means that if the original request was https, then set an Apache environment variable called "HTTPS" so that Apache and PHP will know the request was over https. For some reason, though, X-Forwarded-Proto is always "http" and never "https" in your configuration. Since you are setting the WordPress URL to always be https, I have just set this Apache environment variable unconditionally via this statement:

      SetEnv HTTPS on

      That gives the proper result, a WordPress login screen. I think it would be good to have the load balancer enforce https, but I can't enable that without the private key.

      This appears to now be fixed.

      regards

      David
    • This image is hidden for guests.
      Please log in or register to see it.

      Wicko Design is a multi-disciplined creative agency based in the South East of England. Specialising in web design and development, retail packaging and brand identity.

      http://www.wickodesign.com
    • Wicko's Avatar
    • Wicko
    • Elite Rocketeer
    • Posts: 792
    • Thanks: 7
    • Self employed Graphic designer with over 20 years of experience in branding, retail packaging and web design.

    Re: WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • Did notice that any images loaded into blog posts from RokGallery still showed as http and had to go into each post and change to remove the http: which fixed these pages
    • This image is hidden for guests.
      Please log in or register to see it.

      Wicko Design is a multi-disciplined creative agency based in the South East of England. Specialising in web design and development, retail packaging and brand identity.

      http://www.wickodesign.com
    • Matt's Avatar
    • Matt
    • Preeminent Rocketeer
    • Posts: 20628
    • Thanks: 2924
    • messin' with stuff

    Re: WP Rokgallery links not updating to https

    Posted 2 years 11 months ago
    • ty for posting your solution and marking solved... yes, links embedded within posts or text widgets are static/not-relative (as they're user configured/insterted, not plugin/dynamically inserted) and will have to be updated... posts live in the DB so you can use a MySQL find/replace script to mass-update if needed
    • SEARCH the forum first! These boards are rich in knowledge and vast in topics :woohoo:

Time to create page: 0.067 seconds