0
Welcome Guest! Login
0 items Join Now

Audacity will not update widget styles

  • Audacity will not update widget styles

    Posted 5 years 1 month ago
    • I have finally started updating a website using Gantry 4 and the Audacity Theme. In most cases things seem to work, but I have found that updateds don't always "take" the first or second time. My current problem: On my front page, I renamed the original front page template and have assigned it to my front page. I have added widgets in "top, header,..., footer" areas. After filling out the widgets, I move on to fix the style and layouts of my frontpage and page template. I everything seems to save and update except the backgroup color of the "top" area. There is a custom logo widget put into the "top". The "menu" is in the "header". I want the backgrounds to match. Only the "header" area has the correctly colored background. The "top" does not change from the "page" color regardless of the color I choose or how many time I change and save it. Does anyone have any idea where I might look to solve the problem. Thanks! -J
    • Damir's Avatar
    • Damir
    • Preeminent Rocketeer
    • Posts: 22450
    • Thanks: 2676
    • Web Developer

    Re: Audacity will not update widget styles

    Posted 5 years 1 month ago
    • Kat05's Avatar
    • Kat05
    • Preeminent Rocketeer
    • Posts: 25898
    • Thanks: 334

    Re: Audacity will not update widget styles

    Posted 5 years 1 month ago
    • Hi Damir,

      member replied to the email notification, here is the response
      Hi Damir-


      Thanks for getting back so quickly. I'm sorry to bother you all, but this is really annoying. I tried as you suggested. I also tried all different ways of doing the same thing in different orders and with different options. I can place the logo in the header, but not the top or the drawer. No matter what I change, the top section always reverts to the background color on the page. I have included some images here in case you wanted to see what things looked like. Let me know if you have any other ideas.


      Thanks again!

      - John
    • Kat05 / QA Lead & Support / Germany
    • Damir's Avatar
    • Damir
    • Preeminent Rocketeer
    • Posts: 22450
    • Thanks: 2676
    • Web Developer

    Re: Audacity will not update widget styles

    Posted 5 years 1 month ago
  • Re: Audacity will not update widget styles

    Posted 5 years 1 month ago
    • Here is the info to the site.

      Thanks again for the help.

      -J
  • Re: Audacity will not update widget styles

    Posted 5 years 4 weeks ago
    • Hello Damir-

      I thought I would give you the latest update. Audacity/Wordpress was not allowing me to update the "styles" section of the "top" of my page using the gentry 4 override. I decided to shrink the logo and move it to the "header". This worked. Then I added a new page override and assigned it to my standard posts/pages. Now my problem is, once past the home page, no pages open. Using the first column of options in the footer is how I test. Any of those choices should be a link, but instead I get:

      1. A blank page with a ">" symbol in the top left corner
      2. An error message: Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 98245 bytes) in /***/***/public_html/wp-includes/functions.php on line 354

      I was wondering if both problems could be caused by webserver memory problems? If so, how might I fix them. I have seen some references to editing a "php.ini" file, but nothing concrete. I will wait to do anything more until I hear from you. Thanks for your help and instruction.

      Regards,
      -J
    • Damir's Avatar
    • Damir
    • Preeminent Rocketeer
    • Posts: 22450
    • Thanks: 2676
    • Web Developer

    Re: Audacity will not update widget styles

    Posted 5 years 4 weeks ago
  • Re: Audacity will not update widget styles

    Posted 5 years 3 weeks ago
    • Hello Damir-

      Sorry to take so long to get back to you. I've been testing etc. and here is where I am at. I have about had it with Gantry 4 / Audacity. I have read all the docs, been through the tutorials, and nothing works as it should. Damir asked me to upgrade my level of server because the site was slow. I did that and it didn't help. I finally pulled all the plugins and installed the latest versions. I thought that might help as I was finally able to get into the backend again. While the site now works again, and I have put my server level of support back on one because I am the only person actually doing anything with the site right now, let me write about the issues I have had today.

      1. I have attempted to create 3 Gantry Overrides for 3 types of pages. None of the layouts match with the widgets and columns I set up. The widgets sometimes show information correctly, sometimes they show old information that I deleted. Sometimes one widget will show up in a completely different page section. Sometimes widgets will even show on the wrong pages. I have had to completely delete all information and widgets, and then slowly rebuild them all back in order with making any mistakes, or I have to redo the whole page as I am not able to fix or update any mistakes.

      2. RokSprocket quit working. It was working fine until I updated the plugins. Afterwards, the old stuff I created worked, but I could not create any new stuff. I reinstall new downloads of RokCommon and RokSprocket, and now all of the stuff I created has disappeared along with all the examples. I still can't load any media from the libraries, and I can't delete anything in the lists.

      I don't know if changing the level of server back to 3 will fix anything, but I don't feel that is the cause of the problems. When I first played with this about a year ago, I did not have nearly this amount of problems. I have all the latest plugins and I don't see any real obvious issues. I am going to continue moving pages, posts, and media over to this site in the hopes that someone here can help me figure out just what exactly is happening.

      If you need anything from me, please let me know as I would really like to get back to actual work. Thank you all for your help and time.
    • Damir's Avatar
    • Damir
    • Preeminent Rocketeer
    • Posts: 22450
    • Thanks: 2676
    • Web Developer

    Re: Audacity will not update widget styles

    Posted 5 years 3 weeks ago
  • Re: Audacity will not update widget styles

    Posted 5 years 3 weeks ago
    • Hi Damir-

      I went to look at things. I still can not add any images to the existing roksprocket created "shows". I can not delete the existing roksprocket created "shows". I have tried use the images that exist in the media library as well as adding new ones. The images are fine and I can place them in posts and pages, just not in the roksprocket created "shows". I would also like to know where the sample roksprocket examples disappeared to. I'm not sure what you mean by using the override for the front page. I assign all the frontpage and homepage stuff to my own override "*** Home Page".

      As mentioned, I have different footers assigned in different overrides assigned to multiple pages. After reading the "manual" my understanding is that things should work like this:

      1. If I add something to the "default", then every override I create from that default will begin with those settings.
      2. If I use an existing override to create another, then the one I created will start with the settings from the one I copied.
      3. If I change something in "page override 2" which was created from "page override 1", then the pages/posts I assign to "page override 2" will be different than the pages/posts I assign to "page override 1".

      None of this has proven to be true. I have footers that show up on the incorrect pages becasuse the widgets don't save where I have put them. I have old widgets overrun new widgets. I have text that has disappeared. If I change a layout or style in one override, then go back to that override later, the styles and layouts are different. I have had to redo footers and headers multiple times (in some cases up to 7 times). The only way I have been able to get an override to work correctly is to start with a new override, place my widgets in the exact order I want, and then create whatever is going into the widget at the time I added it to a section. Anything else is problematic. I can't edit anything in an override because something else will change somewhere else in that same override.

      I have tried working from different computers, but had the same problems. I would like to know if I am missing something, misunderstanding the whole Gantry/Audacity thing, or whatever. I will never be able to finish a site with these kinds of problems. It would be much easier to just write the CSS and be done with it. Anything you can point me to would be of great help.

      Thanks-
      - J

Time to create page: 0.105 seconds