0
Welcome Guest! Login
0 items Join Now

SOLVED Menu Base Item (start level) not working in WP

  • SOLVED Menu Base Item (start level) not working in WP

    Posted 10 months 3 days ago
    • With a multi-level menu, I want to use specific child menus on certain pages, so when someone is using the mobile version of the site, they can see the most relevant menu list when they tap the mobile menu.

      Using the Hydrogen theme, it seems like setting the menu base item on the menu particle (ex. 2nd level child) does not work. The 1st level or parent base seems to work fine. Anything below that, does not work. Is anyone else having this issue? I tried it with different options, adjusting the levels and checking and unchecking things in case there was a bug. Nothing works. Also, if you change the level to 2, the menu just disappears.

      I was able to find a github link and it seems relevant to the issue I am experiencing with WP.
      https://github.com/gantry/gantry5/issues/2181


      For example:
      If someone is on "Service 1" on mobile, I want to show the "Services Parent" and all of its menu items on the mobile menu first. And if they go deeper into "Service 1c", they will only see all "Service 1" options.

      Menu Example:
      Home - Services - About - Contact
      - Service 1
      - Service 1a
      - Service 1b
      - Service 1c
      - Service 2
      - Service 2a
      - Service 2b
      - Service 3
      - Service 4
    • Last Edit: 10 months 3 days ago by tecnicabjj.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 95774
    • Thanks: 12656
    • Web Designer/Developer

    Re: SOLVED Menu Base Item (start level) not working in WP

    Posted 10 months 3 days ago
    • As you have seen, there is an outstanding issue for this on the G5 project an d it has not yet been fixed. In Gantry 5.5 this will be fixed as the menu system has undergone a major rewrite... We won't be releasing this version though until after Joomla 4 has been released.

      Regards, Mark.
    • The following users have thanked you: tecnicabjj

    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: SOLVED Menu Base Item (start level) not working in WP

    Posted 10 months 2 days ago
    • As always, thanks Mark! Glad to hear things are coming down the pipeline. Just wish Joomla 4 would come sooner and want to use it for upcoming projects.

Time to create page: 0.099 seconds