0
Welcome Guest! Login
0 items Join Now

Issue with wordpress themes after 5.8 update

    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 95771
    • Thanks: 12656
    • Web Designer/Developer

    Re: Issue with wordpress themes after 5.8 update

    Posted 2 months 1 week ago
    • Unfortunately Linda I can see no way out of this as there is no longer anyway back into your site. The error you are getting IS related to the issues we have seen and the introduction of the new block editor in WP5.8. So our advice still stands that you should not update to WP5.8 until such time as we release compatible versions of Gantry.

      Your issues seem to be compounded by the fact that you have both Gantry 4 and Gantry 5 installed and active.

      All I can suggest is that you regress to an earlier backup. Even when we do release new versions of Gantry it's not going to help you as you cannot get back into your site to do the updates.

      Sorry I can't help.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • safeworld4women's Avatar
    • safeworld4women
    • Elite Rocketeer
    • Posts: 556
    • Thanks: 20
    • Website designer and Administrator

    Re: Issue with wordpress themes after 5.8 update

    Posted 2 months 1 week ago
    • Hi Mark
      When the problems are solved can you put an update in this thread?
      So people who are following it can be quickly in the know?
      And maybe any progress reports you come across?

      Thanks

      Andrew
    • My wife and I design, build and maintain websites as volunteers - for non-profit organisations. And occasionally for therapists, musicians and artists.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 95771
    • Thanks: 12656
    • Web Designer/Developer

    Re: Issue with wordpress themes after 5.8 update

    Posted 2 months 1 week ago
    • I'll try and remember but I can't guarantee it. When a new version of Gantry 5 is released it will show as such in your site.
      No, I won't be doing progress reports - subscribe to the github ticket isf you want to see that.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • Lukas's Avatar
    • Lukas
    • Rocketeer
    • Posts: 55
    • Thanks: 1

    Re: Issue with wordpress themes after 5.8 update

    Posted 1 month 2 weeks ago
    • Hi @MrT,

      I come back with a question, the first original post was about Gantry version 4, many pages still use 4 versions, including a few mine. Today I noticed this error and after upgrading to WordPRess 5.8 from Gantry 4, a blank page appears when entering Widgets. There are a lot of errors in the console.

      The link you provided is for Gantry 5, not 4 - github.com/gantry/gantry5/issues/2843

      Two days ago it was marked as resolved and today it is closed. Does this mean that Gantry 4 for WordPress will also get an update?

      Please give me some information regarding Gantry 4 for WordPress and this issue.
    • The following users have thanked you: safeworld4women

    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 95771
    • Thanks: 12656
    • Web Designer/Developer

    Re: Issue with wordpress themes after 5.8 update

    Posted 1 month 2 weeks ago
    • Lukas - We've been working hard on the damage inflicted by Wordpress 5.8 on Gantry 5 first as this is our most popular framework.

      We will be looking at Gantry 4 too and we're really hoping that we can make that work with WP5.8 too but we won't know for sure until we really get into the detail. Wordpress 5.8 is supposed to have a "legacy" mode - but it doesn't really seem to work for anything but the simplest of widgets.

      When I have any further information I will share it. I did make this announcement nearly a month ago too https://rockettheme.com/forum/announcements-all/286994-wordpress-5-8-please-delay-updating

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.141 seconds